Upgrading from API v1.0 to v2.0

The release of version 2.0 of the SignEasy REST API brings new features, capabilities and improvements. Upgrading your existing integrations from v1.0 to v2.0 of the SignEasy REST APIs gives you the power to take advantage of new capabilities in your workflow, but incompatible changes in v2.0 will require you to update your code.

We will continue to support v1.0 through Dec, 2021.

New capabilities added in the version:

  • Ability to send multiple original documents in a single request.
  • Ability to suppress events to send the relevant webhook requests from Signeasy servers to your endpoints.
  • Ability to add tokens to secure the webhook requests from Signeasy servers to your endpoints.

Incompatible changes appear in the following areas:

  • The syntax of API calls for managing and accessing original documents [Link].
  • The syntax of API calls for signature request calls with/without fields. [Link]
  • The syntax of API calls for signature request calls using templates with / without merge fields. [Link]
  • The syntax of the API calls for web-hooks. [Link]
  • The syntax of the API calls for Embedded Sending requests. [Link]

Please reach out to [email protected] for any questions or guidance while migrating your current application to v2.0.